CVE-2020-9402

Priority
Description
Django 1.11 before 1.11.29, 2.2 before 2.2.11, and 3.0 before 3.0.4 allows
SQL Injection if untrusted data is used as a tolerance parameter in GIS
functions and aggregates on Oracle. By passing a suitably crafted tolerance
to GIS functions and aggregates on Oracle, it was possible to break
escaping and inject malicious SQL.
Assigned-to
mdeslaur
Notes
Package
Upstream:released (2.2.11,1.11.29)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):not-affected
Ubuntu 16.04 LTS (Xenial Xerus):released (1.8.7-1ubuntu5.12)
Ubuntu 18.04 LTS (Bionic Beaver):released (1:1.11.11-1ubuntu1.8)
Ubuntu 19.10 (Eoan Ermine):released (1:1.11.22-1ubuntu1.3)
Ubuntu 20.04 (Focal Fossa):released (2:2.2.10-1ubuntu1)
More Information

Updated: 2020-03-18 22:55:14 UTC (commit 2ea7df7bd1e69e1e489978d2724a936eb3faa1b8)