CVE-2020-8794

Priority
Description
OpenSMTPD before 6.6.4 allows remote code execution because of an
out-of-bounds read in mta_io in mta_session.c for multi-line replies.
Although this vulnerability affects the client side of OpenSMTPD, it is
possible to attack a server because the server code launches the client
code during bounce handling.
Notes
Package
Upstream:released (6.6.4p1-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected [code not present])
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):released (6.0.3p1-1ubuntu0.2)
Ubuntu 19.10 (Eoan Ermine):released (6.0.3p1-6ubuntu0.2)
Ubuntu 20.04 (Focal Fossa):released (6.6.4p1-1)
More Information

Updated: 2020-03-18 21:44:54 UTC (commit 2ea7df7bd1e69e1e489978d2724a936eb3faa1b8)