CVE-2020-8130

Priority
Description
There is an OS command injection vulnerability in Ruby Rake < 12.3.3 in
Rake::FileList when supplying a filename that begins with the pipe
character `|`.
Assigned-to
leosilva
Notes
Package
Source: rake (LP Ubuntu Debian)
Upstream:released (12.3.3-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (10.5.0-2ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (12.3.1-1ubuntu0.1)
Ubuntu 19.10 (Eoan Ermine):released (12.3.1-3ubuntu0.1)
Ubuntu 20.04 (Focal Fossa):not-affected (13.0.1-2)
Patches:
Upstream:https://github.com/ruby/rake/commit/5b8f8fc41a5d7d7d6a5d767e48464c60884d3aee
More Information

Updated: 2020-03-18 22:55:13 UTC (commit 2ea7df7bd1e69e1e489978d2724a936eb3faa1b8)