CVE-2020-1930

Priority
Description
A command execution issue was found in Apache SpamAssassin prior to 3.4.3.
Carefully crafted nefarious rule configuration (.cf) files can be
configured to run system commands similar to CVE-2018-11805. With this bug
unpatched, exploits can be injected in a number of scenarios including the
same privileges as spamd is run which may be elevated though doing so
remotely is difficult. In addition to upgrading to SA 3.4.4, we again
recommend that users should only use update channels or 3rd party .cf files
from trusted places. If you cannot upgrade, do not use 3rd party rulesets,
do not use sa-compile and do not run spamd as an account with elevated
privileges.
Assigned-to
mdeslaur
Notes
Package
Upstream:released (3.4.4~rc1-1)
Ubuntu 12.04 ESM (Precise Pangolin):released (3.4.2-0ubuntu0.12.04.4)
Ubuntu 14.04 ESM (Trusty Tahr):released (3.4.2-0ubuntu0.14.04.1+esm2)
Ubuntu 16.04 LTS (Xenial Xerus):released (3.4.2-0ubuntu0.16.04.3)
Ubuntu 18.04 LTS (Bionic Beaver):released (3.4.2-0ubuntu0.18.04.3)
Ubuntu 19.10 (Eoan Ermine):released (3.4.2-1ubuntu0.19.10.2)
Ubuntu 20.04 (Focal Fossa):not-affected (3.4.4~rc1-1)
More Information

Updated: 2020-02-05 18:15:19 UTC (commit 1ebdd381034966b617b2f0962b7d8237bb2694ea)