CVE-2020-1712

Priority
Description
A heap use-after-free vulnerability was found in systemd before version
v245-rc1, where asynchronous Polkit queries are performed while handling
dbus messages. A local unprivileged attacker can abuse this flaw to crash
systemd services or potentially execute code and elevate their privileges,
by sending specially crafted dbus messages.
Assigned-to
mdeslaur
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):released (229-4ubuntu21.27)
Ubuntu 18.04 LTS (Bionic Beaver):released (237-3ubuntu10.38)
Ubuntu 19.10 (Eoan Ermine):released (242-7ubuntu3.6)
Ubuntu 20.04 (Focal Fossa):released (244.1-0ubuntu3)
Patches:
Upstream:https://github.com/poettering/systemd/commits/polkit-ref-count
Upstream:https://github.com/systemd/systemd/commit/ea0d0ede03c6f18dbc5036c5e9cccf97e415ccc2
More Information

Updated: 2020-04-24 03:59:02 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)