CVE-2020-14059

Priority
Description
An issue was discovered in Squid 5.x before 5.0.3. Due to an Incorrect
Synchronization, a Denial of Service can occur when processing objects in
an SMP cache because of an Ipc::Mem::PageStack::pop ABA problem during
access to the memory page/slot management list.
Notes
mdeslaurthis only affected Squid 5.x
Package
Source: squid (LP Ubuntu Debian)
Upstream:not-affected (debian: vulnerability introduced in the 5.x series)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 20.04 LTS (Focal Fossa):not-affected (code not present)
Ubuntu 20.10 (Groovy Gorilla):not-affected (code not present)
Package
Upstream:not-affected (debian: vulnerability introduced in the 5.x series)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (code not present)
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (code not present)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (code not present)
Ubuntu 20.04 LTS (Focal Fossa):DNE
Ubuntu 20.10 (Groovy Gorilla):DNE
More Information

Updated: 2020-07-28 20:08:15 UTC (commit d26b6ca9f5b3adb89bb036ce73ae7dab894935ec)