CVE-2020-14058

Priority
Description
An issue was discovered in Squid before 4.12 and 5.x before 5.0.3. Due to
use of a potentially dangerous function, Squid and the default certificate
validation helper are vulnerable to a Denial of Service when opening a TLS
connection to an attacker-controlled server for HTTPS. This occurs because
unrecognized error values are mapped to NULL, but later code expects that
each error value is mapped to a valid error string.
Notes
mdeslaurIn Ubuntu, squid is built without openssl support, so this
is not an issue.
Package
Source: squid (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 20.04 LTS (Focal Fossa):not-affected (code not compiled)
Ubuntu 20.10 (Groovy Gorilla):not-affected (code not compiled)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (code not compiled)
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (code not compiled)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (code not compiled)
Ubuntu 20.04 LTS (Focal Fossa):DNE
Ubuntu 20.10 (Groovy Gorilla):DNE
More Information

Updated: 2020-07-28 20:08:15 UTC (commit d26b6ca9f5b3adb89bb036ce73ae7dab894935ec)