CVE-2020-12692

Priority
Description
An issue was discovered in OpenStack Keystone before 15.0.1, and 16.0.0.
The EC2 API doesn't have a signature TTL check for AWS Signature V4. An
attacker can sniff the Authorization header, and then use it to reissue an
OpenStack token an unlimited number of times.
Notes
Package
Upstream:released (13.0.4,15.0.1,16.0.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):released (2:13.0.4-0ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa):not-affected (2:17.0.0-0ubuntu0.20.04.1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (2:18.0.0~b2~git2020073017.b187dfd05-0ubuntu1)
Patches:
Upstream:https://opendev.org/openstack/keystone/commit/1c1cf556f81058a63ea0bd5138540b0e6795f7a0 (pike)
Upstream:https://opendev.org/openstack/keystone/commit/b25739fa9605cc54bc98325c2a92360ba702e8d8 (queens)
More Information

Updated: 2020-09-09 23:34:57 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)