CVE-2020-11945

Priority
Description
An issue was discovered in Squid before 5.0.2. A remote attacker can replay
a sniffed Digest Authentication nonce to gain access to resources that are
otherwise forbidden. This occurs because the attacker can overflow the
nonce reference counter (a short integer). Remote code execution may occur
if the pooled token credentials are freed (instead of replayed as valid
credentials).
Assigned-to
mdeslaur
Notes
Package
Source: squid (LP Ubuntu Debian)
Upstream:released (4.11)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.10 (Eoan Ermine):released (4.8-1ubuntu2.3)
Ubuntu 20.04 LTS (Focal Fossa):released (4.10-1ubuntu1.1)
Ubuntu 20.10 (Groovy Gorilla):released (4.10-1ubuntu2)
Patches:
Upstream:http://www.squid-cache.org/Versions/v4/changesets/squid-4-eeebf0f37a72a2de08348e85ae34b02c34e9a811.patch
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (3.5.12-1ubuntu7.11)
Ubuntu 18.04 LTS (Bionic Beaver):released (3.5.27-1ubuntu1.6)
Ubuntu 19.10 (Eoan Ermine):DNE
Ubuntu 20.04 LTS (Focal Fossa):DNE
Ubuntu 20.10 (Groovy Gorilla):DNE
More Information

Updated: 2020-05-13 19:14:29 UTC (commit 28f9b2c2acd1fa9ed861c4413d9abb6607b429b5)