CVE-2019-9787

Priority
Description
WordPress before 5.1.1 does not properly filter comment content, leading to
Remote Code Execution by unauthenticated users in a default configuration.
This occurs because CSRF protection is mishandled, and because Search
Engine Optimization of A elements is performed incorrectly, leading to XSS.
The XSS results in administrative access, which allows arbitrary changes to
.php files. This is related to wp-admin/includes/ajax-actions.php and
wp-includes/comment.php.
Notes
Package
Upstream:released (5.1.1+dfsg1-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needs-triage)
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 19.10 (Eoan Ermine):not-affected (5.1.1+dfsg1-1)
Ubuntu 20.04 (Focal Fossa):not-affected (5.1.1+dfsg1-1)
More Information

Updated: 2020-01-29 19:05:05 UTC (commit 40f18bf14da5fb50662e1f861ea594a462b207fe)