The implementations of EAP-PWD in hostapd EAP Server, when built against a
crypto library missing explicit validation on imported elements, do not
validate the scalar and element values in EAP-pwd-Commit. An attacker may
be able to use invalid scalar/element values to complete authentication,
gaining session key and network access without needing or learning the
password. Both hostapd with SAE support and wpa_supplicant with SAE support
prior to and including version 2.4 are affected. Both hostapd with EAP-pwd
support and wpa_supplicant with EAP-pwd support prior to and including
version 2.7 are affected.
Source: wpa (LP Ubuntu Debian)
Upstream:released (2.8)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):released (2.1-0ubuntu1.7)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.4-0ubuntu6.4)
Ubuntu 18.04 LTS (Bionic Beaver):released (2:2.6-15ubuntu2.2)
Ubuntu 19.04 (Disco Dingo):released (2:2.6-21ubuntu3)
Ubuntu 19.10 (Eoan Ermine):released (2:2.6-21ubuntu3)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (code not present)
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan Ermine):DNE
More Information

Updated: 2019-12-05 21:10:14 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)