CVE-2019-9498 (retired)

Priority
Description
The implementations of EAP-PWD in hostapd EAP Server, when built against a
crypto library missing explicit validation on imported elements, do not
validate the scalar and element values in EAP-pwd-Commit. An attacker may
be able to use invalid scalar/element values to complete authentication,
gaining session key and network access without needing or learning the
password. Both hostapd with SAE support and wpa_supplicant with SAE support
prior to and including version 2.4 are affected. Both hostapd with EAP-pwd
support and wpa_supplicant with EAP-pwd support prior to and including
version 2.7 are affected.
Package
Source: wpa (LP Ubuntu Debian)
Upstream:released (2.8)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):released (2.1-0ubuntu1.7)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.4-0ubuntu6.4)
Ubuntu 18.04 LTS (Bionic Beaver):released (2:2.6-15ubuntu2.2)
Ubuntu 18.10 (Cosmic Cuttlefish):released (2:2.6-18ubuntu1.1)
Ubuntu 19.04 (Disco Dingo):released (2:2.6-21ubuntu3)
Ubuntu 19.10 (Eoan):released (2:2.6-21ubuntu3)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (code not present)
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
More Information

Updated: 2019-05-10 15:14:52 UTC (commit 3c00b0ed9466e443831508364cb19328f87345f9)