CVE-2019-9497 (retired)

The implementations of EAP-PWD in hostapd EAP Server and wpa_supplicant EAP
Peer do not validate the scalar and element values in EAP-pwd-Commit. This
vulnerability may allow an attacker to complete EAP-PWD authentication
without knowing the password. However, unless the crypto library does not
implement additional checks for the EC point, the attacker will not be able
to derive the session key or complete the key exchange. Both hostapd with
SAE support and wpa_supplicant with SAE support prior to and including
version 2.4 are affected. Both hostapd with EAP-pwd support and
wpa_supplicant with EAP-pwd support prior to and including version 2.7 are
Source: wpa (LP Ubuntu Debian)
Upstream:released (2.8)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):released (2.1-0ubuntu1.7)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.4-0ubuntu6.4)
Ubuntu 18.04 LTS (Bionic Beaver):released (2:2.6-15ubuntu2.2)
Ubuntu 19.04 (Disco Dingo):released (2:2.6-21ubuntu3)
Ubuntu 19.10 (Eoan):released (2:2.6-21ubuntu3)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (code not present)
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
More Information

Updated: 2019-09-19 16:07:39 UTC (commit d32ebc32606b9517c6fa7d65a15441e2a57a6de5)