CVE-2019-8942

Priority
Description
WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution
because an _wp_attached_file Post Meta entry can be changed to an arbitrary
string, such as one ending with a .jpg?file.php substring. An attacker with
author privileges can execute arbitrary code by uploading a crafted image
containing PHP code in the Exif metadata. Exploitation can leverage
CVE-2019-8943.
Notes
Package
Upstream:released (5.0.1+dfsg1-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 19.10 (Eoan Ermine):not-affected (5.0.3+dfsg1-1)
Ubuntu 20.04 (Focal Fossa):not-affected (5.0.3+dfsg1-1)
More Information

Updated: 2020-02-07 11:14:26 UTC (commit 274c2aa8c467e8ed275a5451863a43e87aeec3ca)