CVE-2019-6799

Priority
Description
An issue was discovered in phpMyAdmin before 4.8.5. When the
AllowArbitraryServer configuration setting is set to true, with the use of
a rogue MySQL server, an attacker can read any file on the server that the
web server's user can access. This is related to the
mysql.allow_local_infile PHP configuration, and the inadvertent ignoring of
"options(MYSQLI_OPT_LOCAL_INFILE" calls.
Notes
Package
Upstream:released (4.8.5, 4:4.9.1+dfsg1-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 20.04 LTS (Focal Fossa):not-affected (4:4.9.2+dfsg1-1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (4:4.9.2+dfsg1-1)
Patches:
Upstream:https://github.com/phpmyadmin/phpmyadmin/commit/aeac90623e525057a7672ab3d98154b5c57c15ec
Upstream:https://github.com/phpmyadmin/phpmyadmin/commit/c5e01f84ad48c5c626001cb92d7a95500920a900
More Information

Updated: 2020-07-28 18:58:36 UTC (commit 7b6828437fde0509248708fcdb5b0f7587b85bd1)