CVE-2019-5164

Priority
Description
An exploitable code execution vulnerability exists in the ss-manager binary
of Shadowsocks-libev 3.3.2. Specially crafted network packets sent to
ss-manager can cause an arbitrary binary to run, resulting in code
execution and privilege escalation. An attacker can send network packets to
trigger this vulnerability.
Notes
Package
Upstream:released (3.3.3+ds-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 19.04 (Disco Dingo):ignored (reached end-of-life)
Ubuntu 19.10 (Eoan Ermine):needs-triage
Ubuntu 20.04 (Focal Fossa):not-affected (3.3.3+ds-3)
More Information

Updated: 2020-01-23 20:51:13 UTC (commit b4629892d998f2ede31f59bb7508dc50a92ac664)