CVE-2019-5163

Priority
Description
An exploitable denial-of-service vulnerability exists in the UDPRelay
functionality of Shadowsocks-libev 3.3.2. When utilizing a Stream Cipher
and a local_address, arbitrary UDP packets can cause a FATAL error code
path and exit. An attacker can send arbitrary UDP packets to trigger this
vulnerability.
Notes
Package
Upstream:released (3.3.3+ds-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 19.04 (Disco Dingo):ignored (reached end-of-life)
Ubuntu 19.10 (Eoan Ermine):needs-triage
Ubuntu 20.04 (Focal Fossa):not-affected (3.3.3+ds-3)
More Information

Updated: 2020-01-23 20:51:13 UTC (commit b4629892d998f2ede31f59bb7508dc50a92ac664)