CVE-2019-3859

Priority
Description
An out of bounds read flaw was discovered in libssh2 before 1.8.1 in the
_libssh2_packet_require and _libssh2_packet_requirev functions. A remote
attacker who compromises a SSH server may be able to cause a Denial of
Service or read data in the client memory.
Ubuntu-Description
It was discovered that libssh2 incorrectly handled certain specially
crafted packets. A remote attacker could possibly use this issue to cause
a denial of service or obtain sensitive information.
Notes
msalvatoreUpstream fix causes regression:
https://lists.opensuse.org/opensuse-security-announce/2019-04/msg00102.html
Follow up patch: https://github.com/libssh2/libssh2/commit/ca2744483eac4e707084df5fc55cc69d57571dde
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 20.04 LTS (Focal Fossa):not-affected (1.8.0-2.1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (1.8.0-2.1)
More Information

Updated: 2020-09-25 14:24:58 UTC (commit e775549e62f5d80d4ff1c6236719bd55379159c5)