CVE-2019-3855

Priority
Description
An integer overflow flaw which could lead to an out of bounds write was
discovered in libssh2 before 1.8.1 in the way packets are read from the
server. A remote attacker who compromises a SSH server may be able to
execute code on the client system when a user connects to the server.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 18.10 (Cosmic Cuttlefish):ignored (reached end-of-life)
Ubuntu 19.04 (Disco Dingo):not-affected (1.8.0-2.1)
Ubuntu 19.10 (Eoan):not-affected (1.8.0-2.1)
More Information

Updated: 2019-07-18 17:43:16 UTC (commit 649f8c6455205380e35ed054e9ea734222c716bb)