CVE-2019-3839

Priority
Description
It was found that in ghostscript some privileged operators remained
accessible from various places after the CVE-2019-6116 fix. A specially
crafted PostScript file could use this flaw in order to, for example, have
access to the file system outside of the constrains imposed by -dSAFER.
Ghostscript versions before 9.27 are vulnerable.
Assigned-to
mdeslaur
Notes
sbeattiesecond commit avoids pdf2dsc regression
Package
Upstream:released (9.27~dfsg-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (9.26~dfsg+0-0ubuntu0.16.04.9)
Ubuntu 18.04 LTS (Bionic Beaver):released (9.26~dfsg+0-0ubuntu0.18.04.9)
Ubuntu 19.10 (Eoan Ermine):released (9.26~dfsg+0-0ubuntu8)
Patches:
Upstream:http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=4ec9ca74bed49f2a82acb4bf430eae0d8b3b75c9
Upstream:http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=db24f253409d5d085c2760c814c3e1d3fa2dac59
More Information

Updated: 2020-03-18 22:54:34 UTC (commit 2ea7df7bd1e69e1e489978d2724a936eb3faa1b8)