CVE-2019-3835 (retired)

Priority
Description
It was found that the superexec operator was available in the internal
dictionary in ghostscript before 9.27. A specially crafted PostScript file
could use this flaw in order to, for example, have access to the file
system outside of the constrains imposed by -dSAFER.
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (9.26~dfsg+0-0ubuntu0.14.04.8)
Ubuntu 16.04 LTS (Xenial Xerus):released (9.26~dfsg+0-0ubuntu0.16.04.8)
Ubuntu 18.04 LTS (Bionic Beaver):released (9.26~dfsg+0-0ubuntu0.18.04.8)
Ubuntu 18.10 (Cosmic Cuttlefish):released (9.26~dfsg+0-0ubuntu0.18.10.8)
Ubuntu 19.04 (Disco Dingo):released (9.26~dfsg+0-0ubuntu7)
Patches:
Upstream:http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=205591753126802da850ada6511a0ff8411aa287
Upstream:http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=d683d1e6450d74619e6277efeebfc222d9a5cb91
More Information

Updated: 2019-03-29 02:14:58 UTC (commit 4f84fe790cebaab8768c0c369531aca9c55f7450)