CVE-2019-3832

Priority
Description
It was discovered the fix for CVE-2018-19758 (libsndfile) was not complete
and still allows a read beyond the limits of a buffer in wav_write_header()
function in wav.c. A local attacker may use this flaw to make the
application crash.
Assigned-to
mdeslaur
Package
Upstream:released (1.0.28-6)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):released (1.0.25-10ubuntu0.16.04.2)
Ubuntu 18.04 LTS (Bionic Beaver):released (1.0.28-4ubuntu0.18.04.1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (1.0.28-4ubuntu0.18.10.1)
Ubuntu 19.04 (Disco Dingo):not-affected (1.0.28-6)
Ubuntu 19.10 (Eoan):not-affected (1.0.28-6)
Patches:
Upstream:https://github.com/erikd/libsndfile/commit/6d7ce94c020cc720a6b28719d1a7879181790008
More Information

Updated: 2019-06-10 16:14:23 UTC (commit 9506bd8a943d39065c1e0787a0e29ecfa3572e06)