CVE-2019-3813

Priority
Description
Spice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of-bounds
read due to an off-by-one error in memslot_get_virt. This may lead to a
denial of service, or, in the worst case, code-execution by unauthenticated
attackers.
Assigned-to
mdeslaur
Notes
leosilvaIssues that touch python_modules for spice in Xenial
need to be addressed in spice-protocol.
Package
Source: spice (LP Ubuntu Debian)
Upstream:pending (0.14.2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):released (0.12.4-0nocelt2ubuntu1.8)
Ubuntu 16.04 LTS (Xenial Xerus):released (0.12.6-4ubuntu0.4)
Ubuntu 18.04 LTS (Bionic Beaver):released (0.14.0-1ubuntu2.4)
Ubuntu 19.04 (Disco Dingo):released (0.14.0-1ubuntu5)
Package
Upstream:not-affected (code not present)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected [code not present])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (code not present)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (code not present)
Ubuntu 19.04 (Disco Dingo):not-affected (code not present)
Package
Upstream:not-affected (code not present)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected [code not present])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (code not present)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (code not present)
Ubuntu 19.04 (Disco Dingo):not-affected (code not present)
More Information

Updated: 2019-12-05 18:51:33 UTC (commit dd38ff22974aae499eb50644b9d5a2817483cbdb)