CVE-2019-3812

Priority
Description
QEMU, through version 2.10 and through version 3.1.0, is vulnerable to an
out-of-bounds read of up to 128 bytes in the hw/i2c/i2c-ddc.c:i2c_ddc()
function. A local attacker with permission to execute i2c commands could
exploit this to read stack memory of the qemu process on the host.
Package
Source: qemu (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (code not present)
Ubuntu 18.04 LTS (Bionic Beaver):released (1:2.11+dfsg-1ubuntu7.12)
Ubuntu 18.10 (Cosmic Cuttlefish):released (1:2.12+dfsg-3ubuntu8.6)
Ubuntu 19.04 (Disco Dingo):released (1:3.1+dfsg-2ubuntu3)
Ubuntu 19.10 (Eoan):released (1:3.1+dfsg-2ubuntu3)
Patches:
Upstream:https://git.qemu.org/?p=qemu.git;a=commit;h=b05b267840515730dbf6753495d5b7bd8b04ad1c
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
More Information

Updated: 2019-04-22 21:37:28 UTC (commit 750f6738e68600bdf0b7c7ef543b49378c330e4e)