CVE-2019-20807

Priority
Description
In Vim before 8.1.0881, users can circumvent the rvim restricted mode and
execute arbitrary OS commands via scripting interfaces (e.g., Python, Ruby,
or Lua).
Assigned-to
mdeslaur
Notes
Package
Source: vim (LP Ubuntu Debian)
Upstream:released (2:8.1.2136-1)
Ubuntu 12.04 ESM (Precise Pangolin):needed
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):released (2:7.4.1689-3ubuntu1.5)
Ubuntu 18.04 LTS (Bionic Beaver):released (2:8.0.1453-1ubuntu1.4)
Ubuntu 20.04 LTS (Focal Fossa):not-affected (2:8.1.2269-1ubuntu5)
Ubuntu 20.10 (Groovy Gorilla):not-affected (2:8.1.2269-1ubuntu5)
Patches:
Upstream:https://github.com/vim/vim/commit/8c62a08faf89663e5633dc5036cd8695c80f1075
Upstream:https://github.com/vim/vim/commit/54d6fe5e60c0c488a424c078963ead40ae7dc397
More Information

Updated: 2020-10-14 18:14:31 UTC (commit 10b4953a1f5f82ae3420742d1a10e7510b456378)