CVE-2019-20444

Priority
Description
HttpObjectDecoder.java in Netty before 4.1.44 allows an HTTP header that
lacks a colon, which might be interpreted as a separate header with an
incorrect syntax, or might be interpreted as an "invalid fold."
Ubuntu-Description
It was discovered that Netty has HTTP request smuggling vulnerability. A
remote attacker could use it to extract sensitive information.
Notes
Package
Source: netty (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 20.04 LTS (Focal Fossa):not-affected (1:4.1.45-1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (1:4.1.45-1)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):released (3.9.9.Final-1+deb9u1build0.18.04.1)
Ubuntu 20.04 LTS (Focal Fossa):DNE
Ubuntu 20.10 (Groovy Gorilla):DNE
More Information

Updated: 2020-10-06 20:14:31 UTC (commit 7efb916343184e96da89bec731a5a8bf3e56e17f)