CVE-2019-19926

Priority
Description
multiSelect in select.c in SQLite 3.30.1 mishandles certain errors during
parsing, as demonstrated by errors from sqlite3WindowRewrite() calls. NOTE:
this vulnerability exists because of an incomplete fix for CVE-2019-19880.
Assigned-to
mdeslaur
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):released (3.8.2-1ubuntu2.2+esm2)
Ubuntu 16.04 LTS (Xenial Xerus):released (3.11.0-1ubuntu1.4)
Ubuntu 18.04 LTS (Bionic Beaver):released (3.22.0-1ubuntu0.3)
Ubuntu 20.04 LTS (Focal Fossa):not-affected (3.31.1-1ubuntu1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (3.31.1-1ubuntu1)
Patches:
Upstream:https://github.com/sqlite/sqlite/commit/8428b3b437569338a9d1e10c4cd8154acbe33089
More Information

Updated: 2020-09-09 23:04:53 UTC (commit b67d7d8b03f173f825cd706df5bd078bca500b0e)