CVE-2019-19604

Priority
Description
Arbitrary command execution is possible in Git before 2.20.2, 2.21.x before
2.21.1, 2.22.x before 2.22.2, 2.23.x before 2.23.1, and 2.24.x before
2.24.1 because a "git submodule update" operation can run commands found in
the .gitmodules file of a malicious repository.
Assigned-to
mdeslaur
Notes
Package
Source: git (LP Ubuntu Debian)
Upstream:released (1:2.24.0-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.7.4-0ubuntu1.6)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.17.1-1ubuntu0.4)
Ubuntu 19.04 (Disco Dingo):released (1:2.20.1-2ubuntu1.19.04.1)
Ubuntu 19.10 (Eoan Ermine):released (1:2.20.1-2ubuntu1.19.10.1)
Ubuntu 20.04 (Focal Fossa):needed
More Information

Updated: 2020-01-17 14:14:24 UTC (commit bf6663b6d125682a55e4974e72ae8263756c15d6)