CVE-2019-18676

Priority
Description
An issue was discovered in Squid 3.x and 4.x through 4.8. Due to incorrect
input validation, there is a heap-based buffer overflow that can result in
Denial of Service to all clients using the proxy. Severity is high due to
this vulnerability occurring before normal security checks; any remote
client that can reach the proxy port can trivially perform the attack via a
crafted URI scheme.
Assigned-to
mdeslaur
Notes
mdeslaursame fix as CVE-2019-12523
This was fixed in 4.x by rewriting the URI parser to use SBuf.
fixed in Debian's 3.5.23-5+deb9u2
Package
Source: squid (LP Ubuntu Debian)
Upstream:released (4.9-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 20.04 LTS (Focal Fossa):released (4.9-2ubuntu1)
Ubuntu 20.10 (Groovy Gorilla):released (4.9-2ubuntu1)
Patches:
Upstream:http://www.squid-cache.org/Versions/v4/changesets/squid-4-fbbdf75efd7a5cc244b4886a9d42ea458c5a3a73.patch
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 20.04 LTS (Focal Fossa):DNE
Ubuntu 20.10 (Groovy Gorilla):DNE
More Information

Updated: 2020-07-28 18:56:11 UTC (commit 7b6828437fde0509248708fcdb5b0f7587b85bd1)