CVE-2019-18390

Priority
Description
An out-of-bounds read in the vrend_blit_need_swizzle function in
vrend_renderer.c in virglrenderer through 0.8.0 allows guest OS users to
cause a denial of service via VIRGL_CCMD_BLIT commands.
Assigned-to
mdeslaur
Notes
Package
Upstream:released (0.8.1-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 19.10 (Eoan Ermine):needed
Ubuntu 20.04 (Focal Fossa):not-affected (0.8.1-6)
Patches:
Upstream:https://gitlab.freedesktop.org/virgl/virglrenderer/commit/24f67de7a9088a873844a39be03cee6882260ac9
More Information

Updated: 2020-01-29 18:59:27 UTC (commit 40f18bf14da5fb50662e1f861ea594a462b207fe)