CVE-2019-17558

Priority
Description
Apache Solr 5.0.0 to Apache Solr 8.3.1 are vulnerable to a Remote Code
Execution through the VelocityResponseWriter. A Velocity template can be
provided through Velocity templates in a configset `velocity/` directory or
as a parameter. A user defined configset could contain renderable,
potentially malicious, templates. Parameter provided templates are disabled
by default, but can be enabled by setting `params.resource.loader.enabled`
by defining a response writer with that setting set to `true`. Defining a
response writer requires configuration API access. Solr 8.4 removed the
params resource loader entirely, and only enables the configset-provided
template rendering when the configset is `trusted` (has been uploaded by an
authenticated user).
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 19.10 (Eoan Ermine):needs-triage
Ubuntu 20.04 (Focal Fossa):needs-triage
More Information

Updated: 2020-01-29 18:59:21 UTC (commit 40f18bf14da5fb50662e1f861ea594a462b207fe)