CVE-2019-17358

Priority
Description
Cacti through 1.2.7 is affected by multiple instances of lib/functions.php
unsafe deserialization of user-controlled data to populate arrays. An
authenticated attacker could use this to influence object data values and
control actions taken by Cacti or potentially cause memory corruption in
the PHP module.
Notes
Package
Source: cacti (LP Ubuntu Debian)
Upstream:released (0.8.8b+dfsg-8+deb8u8, 1.2.8+ds1-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 19.10 (Eoan Ermine):needed
Ubuntu 20.04 (Focal Fossa):needed
More Information

Updated: 2020-01-29 18:59:17 UTC (commit 40f18bf14da5fb50662e1f861ea594a462b207fe)