CVE-2019-16869

Priority
Description
Netty before 4.1.42.Final mishandles whitespace before the colon in HTTP
headers (such as a "Transfer-Encoding : chunked" line), which leads to HTTP
request smuggling.
Ubuntu-Description
It was discovered that Netty has HTTP request smuggling vulnerability. A
remote attacker could use it to extract sensitive information.
Notes
Package
Source: netty (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 20.04 LTS (Focal Fossa):not-affected (1:4.1.33-3)
Ubuntu 20.10 (Groovy Gorilla):not-affected (1:4.1.33-3)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):released (3.9.9.Final-1+deb9u1build0.18.04.1)
Ubuntu 20.04 LTS (Focal Fossa):DNE
Ubuntu 20.10 (Groovy Gorilla):DNE
More Information

Updated: 2020-10-06 20:14:30 UTC (commit 7efb916343184e96da89bec731a5a8bf3e56e17f)