CVE-2019-16777

Priority
Description
Versions of the npm CLI prior to 6.13.4 are vulnerable to an Arbitrary File
Overwrite. It fails to prevent existing globally-installed binaries to be
overwritten by other package installations. For example, if a package was
installed globally and created a serve binary, any subsequent installs of
packages that also create a serve binary would overwrite the previous serve
binary. This behavior is still allowed in local installations and also
through install scripts. This vulnerability bypasses a user using the
--ignore-scripts install option.
Notes
Package
Source: npm (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 19.10 (Eoan Ermine):needs-triage
Ubuntu 20.04 (Focal Fossa):needs-triage
More Information

Updated: 2020-01-29 18:59:03 UTC (commit 40f18bf14da5fb50662e1f861ea594a462b207fe)