CVE-2019-16255

Priority
Description
Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows
code injection if the first argument (aka the "command" argument) to
Shell#[] or Shell#test in lib/shell.rb is untrusted data. An attacker can
exploit this to call an arbitrary Ruby method.
Assigned-to
leosilva
Notes
Package
Source: jruby (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 19.04 (Disco Dingo):needs-triage
Ubuntu 19.10 (Eoan Ermine):needs-triage
Ubuntu 20.04 (Focal Fossa):needs-triage
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (2.3.1-2~ubuntu16.04.14)
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan Ermine):DNE
Ubuntu 20.04 (Focal Fossa):DNE
Package
Upstream:released (2.5.7-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):released (2.5.1-1ubuntu1.6)
Ubuntu 19.04 (Disco Dingo):released (2.5.5-1ubuntu1.1)
Ubuntu 19.10 (Eoan Ermine):released (2.5.5-4ubuntu2.1)
Ubuntu 20.04 (Focal Fossa):not-affected
Patches:
Upstream:https://github.com/ruby/ruby/commit/3af01ae1101e0b8815ae5a106be64b0e82a58640 (2.5.x)
More Information

Updated: 2019-12-05 20:03:41 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)