CVE-2019-15846

Priority
Description
Exim before 4.92.2 allows remote attackers to execute arbitrary code as
root via a trailing backslash.
Ubuntu-Description
It was discovered that Exim incorrectly handled certain decoding
operations. A remote attacker could possibly use this issue to execute
arbitrary commands.
Mitigation
Add - as part of the mail ACL (the ACL referenced by the main config
option "acl_smtp_mail"):
  deny    condition = ${if eq{\\}{${substr{-1}{1}{$tls_in_sni}}}}
  deny    condition = ${if eq{\\}{${substr{-1}{1}{$tls_in_peerdn}}}}
Assigned-to
amurray
Notes
Package
Source: exim4 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):released (4.82-3ubuntu2.4+esm1)
Ubuntu 16.04 LTS (Xenial Xerus):released (4.86.2-2ubuntu2.5)
Ubuntu 18.04 LTS (Bionic Beaver):released (4.90.1-1ubuntu1.4)
Ubuntu 19.04 (Disco Dingo):released (4.92-4ubuntu1.3)
Ubuntu 19.10 (Eoan Ermine):released (4.92.1-1ubuntu2)
Patches:
Upstream:https://git.exim.org/exim.git/commit/2600301ba6dbac5c9d640c87007a07ee6dcea1f4
More Information

Updated: 2019-12-05 21:10:03 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)