CVE-2019-15694

Priority
Description
TigerVNC version prior to 1.10.1 is vulnerable to heap buffer overflow,
which could be triggered from DecodeManager::decodeRect. Vulnerability
occurs due to the signdness error in processing MemOutStream. Exploitation
of this vulnerability could potentially result into remote code execution.
This attack appear to be exploitable via network connectivity.
Notes
Package
Upstream:released (1.10.1+dfsg-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 19.10 (Eoan Ermine):needs-triage
Ubuntu 20.04 (Focal Fossa):not-affected (1.10.1+dfsg-1)
More Information

Updated: 2020-01-29 18:58:39 UTC (commit 40f18bf14da5fb50662e1f861ea594a462b207fe)