CVE-2019-15145

Priority
Description
DjVuLibre 3.5.27 allows attackers to cause a denial-of-service attack
(application crash via an out-of-bounds read) by crafting a corrupted JB2
image file that is mishandled in JB2Dict::JB2Codec::get_direct_context in
libdjvu/JB2Image.h because of a missing zero-bytes check in
libdjvu/GBitmap.h.
Assigned-to
mdeslaur
Notes
Package
Upstream:released (3.5.27.1-11)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (3.5.27.1-5ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (3.5.27.1-8ubuntu0.1)
Ubuntu 19.04 (Disco Dingo):released (3.5.27.1-10ubuntu0.1)
Ubuntu 19.10 (Eoan Ermine):not-affected (3.5.27.1-11)
Ubuntu 20.04 (Focal Fossa):not-affected (3.5.27.1-11)
Patches:
Upstream:https://sourceforge.net/p/djvu/djvulibre-git/ci/9658b01431cd7ff6344d7787f855179e73fe81a7/
More Information

Updated: 2019-12-05 21:09:59 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)