CVE-2019-14869

Priority
Description
A flaw was found in all versions of ghostscript 9.x before 9.50, where the
`.charkeys` procedure, where it did not properly secure its privileged
calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could
abuse this flaw by creating a specially crafted PostScript file that could
escalate privileges within the Ghostscript and access files outside of
restricted areas or execute commands.
Assigned-to
mdeslaur
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (9.26~dfsg+0-0ubuntu0.16.04.12)
Ubuntu 18.04 LTS (Bionic Beaver):released (9.26~dfsg+0-0ubuntu0.18.04.12)
Ubuntu 19.04 (Disco Dingo):released (9.26~dfsg+0-0ubuntu7.4)
Ubuntu 19.10 (Eoan Ermine):released (9.27~dfsg+0-0ubuntu3.1)
Ubuntu 20.04 (Focal Fossa):released (9.27~dfsg+0-0ubuntu4)
Patches:
Upstream:https://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=485904772c5f0aa1140032746e5a0abfc40f4cef
More Information

Updated: 2019-12-05 21:09:58 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)