CVE-2019-14833

Priority
Description
A flaw was found in Samba, all versions starting samba 4.5.0 before samba
4.9.15, samba 4.10.10, samba 4.11.2, in the way it handles a user password
change or a new password for a samba user. The Samba Active Directory
Domain Controller can be configured to use a custom script to check for
password complexity. This configuration can fail to verify password
complexity when non-ASCII characters are used in the password, which could
lead to weak passwords being set for samba users, making it vulnerable to
dictionary attacks.
Assigned-to
mdeslaur
Notes
mdeslaur4.5+ only
Package
Source: samba (LP Ubuntu Debian)
Upstream:released (4.11.2)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected
Ubuntu 14.04 ESM (Trusty Tahr):not-affected
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2:4.3.11+dfsg-0ubuntu0.16.04.21)
Ubuntu 18.04 LTS (Bionic Beaver):released (2:4.7.6+dfsg~ubuntu-0ubuntu2.13)
Ubuntu 20.04 LTS (Focal Fossa):not-affected (2:4.11.1+dfsg-3ubuntu2)
More Information

Updated: 2020-09-10 06:10:38 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)