CVE-2019-14818

Priority
Description
A flaw was found in all dpdk version 17.x.x before 17.11.8, 16.x.x before
16.11.10, 18.x.x before 18.11.4 and 19.x.x before 19.08.1 where a malicious
master, or a container with access to vhost_user socket, can send specially
crafted VRING_SET_NUM messages, resulting in a memory leak including file
descriptors. This flaw could lead to a denial of service condition.
Notes
Package
Source: dpdk (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):released (17.11.8-0~ubuntu18.04.2)
Ubuntu 20.04 LTS (Focal Fossa):not-affected (18.11.4-1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (18.11.4-1)
More Information

Updated: 2020-07-28 18:55:05 UTC (commit 7b6828437fde0509248708fcdb5b0f7587b85bd1)