CVE-2019-14812

Priority
Description
A flaw was found in all ghostscript versions 9.x before 9.50, in the
.setuserparams2 procedure where it did not properly secure its privileged
calls, enabling scripts to bypass `-dSAFER` restrictions. A specially
crafted PostScript file could disable security protection and then have
access to the file system, or execute arbitrary commands.
Assigned-to
sbeattie
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (9.26~dfsg+0-0ubuntu0.16.04.11)
Ubuntu 18.04 LTS (Bionic Beaver):released (9.26~dfsg+0-0ubuntu0.18.04.11)
Ubuntu 19.10 (Eoan Ermine):released (9.27~dfsg+0-0ubuntu3)
Patches:
Upstream:http://git.ghostscript.com/?p=ghostpdl.git;h=885444fcbe10dc42787ecb76686c8ee4dd33bf33
More Information

Updated: 2020-01-29 20:04:55 UTC (commit 768ceb2fdee6790d707d0f681e1b54916744af1e)