CVE-2019-14751 (retired)

Priority
Description
NLTK Downloader before 3.4.5 is vulnerable to a directory traversal,
allowing attackers to write arbitrary files via a ../ (dot dot slash) in an
NLTK package (ZIP archive) that is mishandled during extraction.
Ubuntu-Description
It was discovered that NLTK mishandled crafted ZIP archives during extraction.
A remote attacker could use this vulnerability to write arbitrary files to the
filesystem
Package
Source: nltk (LP Ubuntu Debian)
Upstream:released (3.4.5)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (3.1-1ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (3.2.5-1ubuntu0.1)
Ubuntu 19.04 (Disco Dingo):released (3.4-1ubuntu0.1)
Ubuntu 19.10 (Eoan):not-affected (3.4.5-1)
Patches:
Upstream:https://github.com/nltk/nltk/commit/f59d7ed8df2e0e957f7f247fe218032abdbe9a10
More Information

Updated: 2019-09-19 16:15:07 UTC (commit 24f8c384ac899afa114012ae5c5a042c4f493f5a)