CVE-2019-14744

Priority
Description
In KDE Frameworks KConfig before 5.61.0, malicious desktop files and
configuration files lead to code execution with minimal user interaction.
This relates to libKF5ConfigCore.so, and the mishandling of .desktop and
.directory files, as demonstrated by a shell command on an Icon line in a
.desktop file.
Ubuntu-Description
It was discovered that KConfig and KDE libraries have a vulnerability
where an attacker could hide malicious code under desktop and
configuration files.
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (5.18.0-0ubuntu1.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (5.44.0-0ubuntu1.1)
Ubuntu 20.04 LTS (Focal Fossa):not-affected (5.60.0-0ubuntu2)
Ubuntu 20.10 (Groovy Gorilla):not-affected (5.60.0-0ubuntu2)
Patches:
Upstream:https://phabricator.kde.org/R237:5d3e71b1d2ecd2cb2f910036e614ffdfc895aa22
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):released (4:4.14.16-0ubuntu3.3)
Ubuntu 18.04 LTS (Bionic Beaver):released (4:4.14.38-0ubuntu3.1)
Ubuntu 20.04 LTS (Focal Fossa):DNE
Ubuntu 20.10 (Groovy Gorilla):DNE
More Information

Updated: 2020-07-30 18:14:31 UTC (commit a3b70c3d501ce61e535d9cd79ccfb402133b155e)