CVE-2019-14438

Priority
Description
A heap-based buffer over-read in xiph_PackHeaders() in modules/demux/xiph.h
in VideoLAN VLC media player 3.0.7.1 allows remote attackers to trigger a
heap-based buffer over-read via a crafted .ogg file.
Package
Source: vlc (LP Ubuntu Debian)
Upstream:released (3.0.8-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):released (3.0.8-0ubuntu18.04.1)
Ubuntu 19.04 (Disco Dingo):released (3.0.8-0ubuntu19.04.1)
Ubuntu 19.10 (Eoan):not-affected (3.0.8-2)
More Information

Updated: 2019-09-19 14:51:44 UTC (commit d32ebc32606b9517c6fa7d65a15441e2a57a6de5)