CVE-2019-13638 (retired)

Priority
Description
GNU patch through 2.7.6 is vulnerable to OS shell command injection that
can be exploited by opening a crafted patch file that contains an ed style
diff payload with shell metacharacters. The ed editor does not need to be
present on the vulnerable system. This is different from CVE-2018-1000156.
Assigned-to
leosilva
Package
Source: patch (LP Ubuntu Debian)
Upstream:released (2.7.6-5)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected
Ubuntu 14.04 ESM (Trusty Tahr):released (2.7.1-4ubuntu2.4+esm1)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.7.5-1ubuntu0.16.04.2)
Ubuntu 18.04 LTS (Bionic Beaver):released (2.7.6-2ubuntu1.1)
Ubuntu 19.04 (Disco Dingo):released (2.7.6-3ubuntu0.1)
Ubuntu 19.10 (Eoan):released (2.7.6-5)
Patches:
Upstream:https://git.savannah.gnu.org/cgit/patch.git/commit/?id=3fcd042d26d70856e826a42b5f93dc4854d80bf0
More Information

Updated: 2019-08-01 00:15:53 UTC (commit 81c090bcde936e7802713b727f30f2f049bcb6a1)