CVE-2019-13045 (retired)

Priority
Description
Irssi before 1.0.8, 1.1.x before 1.1.3, and 1.2.x before 1.2.1, when SASL
is enabled, has a use after free when sending SASL login to the server.
Assigned-to
leosilva
Package
Source: irssi (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (0.8.19-1ubuntu1.9)
Ubuntu 18.04 LTS (Bionic Beaver):released (1.0.5-1ubuntu4.2)
Ubuntu 18.10 (Cosmic Cuttlefish):released (1.1.1-1ubuntu1.2)
Ubuntu 19.04 (Disco Dingo):released (1.2.0-2ubuntu1.1)
Ubuntu 19.10 (Eoan):released (1.2.0-2ubuntu2)
Patches:
Upstream:https://github.com/irssi/irssi/commit/5a67b983dc97caeb5df1139aabd0bc4f260a47d8
More Information

Updated: 2019-07-12 20:15:37 UTC (commit aba04229460ed0a2e5b31ecb09ca6e28585b1590)