CVE-2019-12855

Priority
Description
In words.protocols.jabber.xmlstream in Twisted through 19.2.1, XMPP support
did not verify certificates when used with TLS, allowing an attacker to
MITM connections.
Assigned-to
mdeslaur
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (code not present)
Ubuntu 14.04 ESM (Trusty Tahr):released (13.2.0-1ubuntu1.2+esm1)
Ubuntu 16.04 LTS (Xenial Xerus):released (16.0.0-1ubuntu0.4)
Ubuntu 18.04 LTS (Bionic Beaver):released (17.9.0-2ubuntu0.1)
Ubuntu 19.10 (Eoan Ermine):released (18.9.0-3ubuntu1.1)
Ubuntu 20.04 (Focal Fossa):released (18.9.0-6ubuntu1)
Patches:
Upstream:https://github.com/twisted/twisted/commit/cf8ed69824502cb39b3a077ec596fe01c03b93da
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.10 (Eoan Ermine):DNE
Ubuntu 20.04 (Focal Fossa):DNE
More Information

Updated: 2020-03-30 16:15:05 UTC (commit a305709f4957a75b33fbbc5633e46b2f58671e29)