CVE-2019-10913

Priority
Description
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x
before 4.1.12, and 4.2.x before 4.2.7, HTTP Methods provided as verbs or
using the override header may be treated as trusted input, but they are not
validated, possibly causing SQL injection or XSS. This is related to
symfony/http-foundation.
Notes
Package
Upstream:released (3.4.22+dfsg-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 20.04 LTS (Focal Fossa):not-affected (3.4.22+dfsg-2)
Ubuntu 20.10 (Groovy Gorilla):not-affected (3.4.22+dfsg-2)
Patches:
Upstream:https://github.com/symfony/symfony/commit/944e60f083c3bffbc6a0b5112db127a10a66a8ec
More Information

Updated: 2020-10-24 06:55:17 UTC (commit 69e225d81a6ee3e2e014950178db797c5d4e5009)