CVE-2019-10216

Priority
Description
In ghostscript before version 9.50, the .buildfont1 procedure did not
properly secure its privileged calls, enabling scripts to bypass `-dSAFER`
restrictions. An attacker could abuse this flaw by creating a specially
crafted PostScript file that could escalate privileges and access files
outside of restricted areas.
Ubuntu-Description
Netanel Fisher discovered that the font handler in Ghostscript did not
properly restrict privileged calls when '-dSAFER' restrictions were in
effect. If a user or automated system were tricked into processing a
specially crafted file, a remote attacker could possibly use this issue
to access arbitrary files.
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (9.26~dfsg+0-0ubuntu0.16.04.10)
Ubuntu 18.04 LTS (Bionic Beaver):released (9.26~dfsg+0-0ubuntu0.18.04.10)
Ubuntu 19.04 (Disco Dingo):released (9.26~dfsg+0-0ubuntu7.2)
Ubuntu 19.10 (Eoan Ermine):released (9.26~dfsg+0-0ubuntu9)
Patches:
Upstream:http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=5b85ddd19
More Information

Updated: 2020-01-11 00:17:34 UTC (commit 5ec2e1c4ad61522c91703af34b5efc5215f88d0e)