CVE-2019-10208

Priority
Description
A flaw was discovered in postgresql versions 9.4.x before 9.4.24, 9.5.x
before 9.5.19, 9.6.x before 9.6.15, 10.x before 10.10 and 11.x before 11.5
where arbitrary SQL statements can be executed given a suitable SECURITY
DEFINER function. An attacker, with EXECUTE permission on the function, can
execute arbitrary SQL as the owner of the function.
Ubuntu-Description
Tom Lane discovered that PostgreSQL did not properly restrict
functions declared as "SECURITY DEFINER". An attacker could use this
to execute arbitrary SQL with the permissions of the function owner.
Notes
leosilvasince 9.3 is not supported anymore by upstream
and for now we don't have how to patch it
I'm marking it as ignored.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):released (10.10-0ubuntu0.18.04.1)
Ubuntu 20.04 LTS (Focal Fossa):DNE
Package
Upstream:released (11.5-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 20.04 LTS (Focal Fossa):released (11.5-1)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):ignored
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 20.04 LTS (Focal Fossa):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):ignored
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 20.04 LTS (Focal Fossa):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (9.5.19-0ubuntu0.16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 20.04 LTS (Focal Fossa):DNE
More Information

Updated: 2020-09-10 06:03:58 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)